Linux Manjaro XFCE Spotify Kurulumu

Linux Manjaro XFCE sistemimde son güncellemeden sonra Spotify kurulumunda hata aldım.

Olası Hata Çıktısı

could not satisfy depenencies: libcurl-openssl-1.0: requires openssl-1.0 spotify: requires libcurl-openssl-1.0

Bulunamayan bağımlılıkları yalın halde yüklemek istediğimde ise paket hatası aldım.

Çözüm

Manjaro forumunda konu ile ilgili bir çözüm buldum.

git clone https://aur.archlinux.org/spotify.git
cd spotify
git checkout 28698fb
makepkg -sri

Olası Hata Çıktısı

/usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/share/spotify/spotify)
/usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/share/spotify/spotify)
/usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)

Çözüm

sudo -Rsnc spotify
sudo -Syyuu
sudo pacman -Scc
yaourt -S --m-arg --skippgpcheck --noconfirm libopenssl-1.0-compat
yaourt -S --m-arg --skippgpcheck --noconfirm libcurl-openssl-1.0
yaourt -S spotify

 

Kaynak

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.